How to install and upgrade the runtime environment up to version 1.2.1

This will explain how to install and upgrade the RPA runtime environment when using RPA up to version 1.2.1.

New installation

  1. Execute robot action.

    Tip

    When the “Take screenshot” button in the “Specify the operation target” dialog or the “Select range” button is clicked in a PC where RPA runtime is not installed, the same dialog will be shown.

  2. Download the installer from the link in the dialog. Depending on the dialog displayed, the runtime environment to download will change.

    • If the following is displayed, download the runtime environment for the version indicated in the message.

      ../../../_images/u1_120.en.png
    • If the following is displayed, the old version of the extension option is registered in CELF. Although it operates with the v1.0.1 runtime environment, we recommend that you use the latest extension option.

      ../../../_images/old_u1.en.png

    Note

    After the installation, the number of machines that can run the application will be set to the number permitted under the license agreement. Uninstall the runtime environment from PCs where robot actions have become unnecessary.

  3. Run the installer.

    ../../../_images/u2.en.png
  4. Run the installer and install according to the instructions.

    ../../../_images/u3.en.png
  5. Click the “Continue” button in the dialog, and then re-run the robot action after closing the dialog.

    ../../../_images/u4.en.png

Upgrading

  1. The following message will be shown when the action is executed, then go to the installer download page from the link on the dialog.

    ../../../_images/vup1.en.png

    Hint

    Please check the runtime environment version displayed in the dialog that is to be installed.
    img-install-vup-req-ver
  2. Download the installer of the version specified in the dialog.

    ../../../_images/vup3.en.png
  3. Run the installer.

    ../../../_images/vup4.en.png
  4. Follow the instructions to install.

    ../../../_images/vup6.en.png
  5. If the following uninstallation confirmation message appears while installing, click “Yes”.

    ../../../_images/vup5.en.png
  6. Click the “Continue” button in the dialog, and then re-run the robot action after closing the dialog.

    ../../../_images/u4.en.png

If an error message is displayed

This section explains how to solve errors due to the installation status of the runtime environment.

  • If you encountered the error “The version of the installed runtime environment is not proper.”

    If you see an error message like the following, you are using an older version of the runtime environment or the CELF Extension Option.
    If the same error occurs even if the version of the runtime environment is upgraded according to the procedure of “Upgrading”, please confirm with your CELF administrator that the runtime environment version corresponding to the CELF Extension Option is correct.
    ../../../_images/err3.en.png
  • If the error “Runtime environment was not found.” is generated

    If you see an error message like the following, the runtime environment is not installed. Please refer to “New installation” to install a runtime environment.

    ../../../_images/err1.en.png
  • If the error “Runtime environment may not be installed correctly.” is generated

    If you see an error message like the following, the runtime environment may be corrupted.
    Run installer the same way as “Upgrading” and reinstall the runtime environment.
    ../../../_images/err2.en.png
  • If the following error occurs, even if you install the runtime environment

    There is a possibility that the runtime environment is newer than the extension option registered in CELF.
    Download and install the runtime environment for v1.0.1 or earlier.
    ../../../_images/old_u1.en.png